Dolor de cabeza, cuidado con transparencia y componentes en CS3!

Bueno perdón por descuidar un poco mi blog ya que pues he estado bastante bastante ocupado en un proyecto que ya dentro de poco liberare, el proyecto esta envuelto con ActionScript 3.0 y que por cierto me acuerdo que les debo lo de Enterprise Architect con ActionScript 3.0 prometo ya postearlo el fin de semana. Pues trabajando en este proyecto estaba desarrollando nada de otro mundo un loader que carga un combo box y ese combo a su vez se comunica con AMFPHP.

El escenario es el siguiente:

Tengo un home que carga otros swf atraves de un loader. Dentro de estos swfs tengo componentes de flash, como datagrid, combobox, listbox etc. En esos swfs tengo comunicación con AMFPHP. Pues resulta que localmente todo marchaba de maravilla pero cuando publicabamos no se veia ningun componente. Esto me causo un dolor de cabeza profundo y casi 2 dias de trabajo perdido ya que no sabiamos que pasaba. Nunca imaginamos lo que Rodrigo Garrido (Computer Graphics Director) de Alucinastudio descubrio. En nuestro html donde tenemos embebido el swf tenemos un atributo de wmode=transaparent , lo que hace que el swf sea transparente para que se integre con la parte de el background. Pues nuestra sopresa fue que los componentes al cargar en un loader y con este atributo no funcionan. Lo único que hicimos fue remover el atributo y todo en orden de nuevo.

Asi que moraleja:
Si van a trabajar con componentes en cs3 y transparente el swf abusados, no funciona o al menos a mi no me funciono.

Saludos y no descuidate ya tanto mi blog!

P.D.
Perdon a todos los que fueron al la conferencia de Flex y AIR y que no pude asistir por motivos laborales, en Diciembre tengo por ahi planeado algo para compensar esta falta 😀

Advertisements

2 thoughts on “Dolor de cabeza, cuidado con transparencia y componentes en CS3!

  1. Una duda que me surge con eso… estabas probando en Firefox o en IE… recuerdo que wmode transparent en el zorrito hace que no se puedan poner acentos y demás. Quizás tenga algo que ver. Lo raro es que adobe conoce este bug y no lo corrige… ¿tanto costará solucionarlo?

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s